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EXPERIMENT NO. 02 

 

Objective: Design and analysis of Dipole antenna. 

Software used: HFSS or CST software 

Theory:  

The dipole antenna or dipole aerial is one of the most important and commonly used types of RF 

antenna. It is made up of two radiators oriented in the same direction, sharing a common axis, and 

separated by an air gap. The two radiators are excited by a feed line in the center of the antenna as 

shown in fig1.1. 

 

 

 

Fig1.1. A basic Dipole antenna. 

There are three main parameters that govern the operation of this antenna, they are dipole length, 

air gap, and dipole radius. The air gap and the dipole radius have only minor effects on the 

performance of the dipole. Because of this, their size is typically determined based on the antenna 

manufacturer’s requirements, within a reasonable range. That leaves the dipole length as the 

primary concern when designing antennas of this type. Although the dipole has a physical length, 

when designing antennas it is often much more convenient to refer to the electrical length of the 

antenna rather than the nominal value. Electrical length is the distance from one end of the antenna 

to the other measured in wavelengths of the signal at a specified frequency. Thus, at differing 

frequencies the same electrical length refers to different nominal lengths. Electrical length is 

usually stated in terms of wavelengths, denoted by the greek letter lambda, λ. 



The most common dipoles for practical use are half-wavelength dipole antennas. One of the 

primary advantages of half-wavelength dipoles is that their characteristic impedance is 73 Ω, 

which is very close to the characteristic impedance of commercially available 75 Ω transmission 

lines. In addition, longer dipoles (L > λ) have radiation patterns with multiple lobes, whereas half-

wavelength dipoles only have one lobe. A single lobe pattern is usually preferred because multiple 

lobe patterns can have significant nulls between the lobes, which can be extremely detrimental to 

antenna performance. Finally, half-wavelength dipoles provide an excellent balance by providing 

a more compact, material saving design than longer antennas without realizing the sharp 

performance reduction seen in shorter antennas. These factors have all combined to make half-

wavelength dipoles an attractive and popular choice for antenna designers for many years 

In order to design the half-wavelength dipole depicted in Figure 1.1, the electrical length of λ/2 

must be converted to a nominal value. This can be accomplished through equation (1). 

LD = 𝝺/2                                                                                                                                          (1)                                                                                                      

The electric and magnetic field components of a half-wavelength dipole can be obtained from (2) 

by letting l = λ/2. 
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The directivity of the half-wavelength dipole antenna is given by:  

𝐷0=4𝜋
𝑈𝑚𝑎𝑥

𝑃𝑟𝑎𝑑
≅ 1.643(dimensionless)        = 2.1 dB                                                                                                 (3) 

And the radiation resistance, for a free-space medium (𝜂 = 120𝜋) is given by 

𝑅𝑟=
2𝑃𝑟𝑎𝑑

|𝐼0|
2  ≅73                                                                                                                                                                (4) 

Another advantages of dipole antenna is its radiation pattern. Due their shape and design, dipole 

antennas can be excited by incident electromagnetic waves from a wide range of angles. In the 

azimuth, a dipole is a perfectly symmetrical cylinder. This results in a completely Omni-directional 

(toroidal) radiation pattern. 

3-D and 2-d radiation pattern of dipole antenna are shown below: 



 

Fig2.1 (a) 3-D pattern, and (b) 2-D pattern of 𝝺/2 dipole antenna. 

 

Design Problem  

Design and analysis of Dipole antenna at 900 MHz with 10% IBW (Gain = 2 dB). 

  

Design Procedure using HFSS software: 

1. Start ANSYS Electronics Desktop. Check (and change if necessary) that the working 

mode is Driven Modal, HFSS > Solution Type > Modal.  

2. Set Modeler length units to mm, Modeler > Units > mm. 

3. To draw a dipole element, select Draw > Cylinder and enter calculated values at radius and 

height position. 

 



 
 

4. After drawing the first element of the dipole we will create the second one by symmetry. 

 

 
 

 

5. Select the first cylinder and then select Edit > Duplicate > Around Axis, choose the axis X 

or Y and enter the angle of 180°, Total number 2. 

6. To provide an input source to perform the simulation. Select Draw > Rectangle and draw 

a rectangle (! it’s a surface model not a volume one) between the two wires, as in the figures 

below. 



 
7. Select the drawn rectangle and define it as the input signal area/port HFSS > Excitations > 

Assign > Lumped Port. 

 
 

 
 



8. Select HFSS > Model > Create Open Region. Choose the frequency of interest (around 900 

MHz) and Radiation boundary. 

9. Add a solution. Select HFSS > Analysis Setup > Add Solution Setup 

10. After meshing, we define a broadband analysis. Select the previously defined solution 

(Project Manager > Analysis > Setup1) and add a broadband solution around the frequency 

corresponding to the single frequency solution HFSS > Analysis Setup > Add Frequency 

Sweep. 

11. Select HFSS > Validation Check to verify that all required steps have been completed. 

12. Select HFSS > Analyze All to start the simulation. Click the Show Progress button to view 

the progress of the solver. 

13. Select HFSS > Results > Create Modal Solution Data Report > Rectangular Plot to display 

the S parameter corresponding to input port P1 (in dB). 

14. Similarly plot far-fields parameters of the antenna.  

 

Simulated Results: 

Add various plots for the designed antenna performances: 

1. -10 dB impedance bandwidth (in GHz) 

2. Gain variations over whole operating BW (in dB) 

3. 2-D radiation patterns at resonating frequency. 

4. 3-D radiation patterns at resonating frequency. 

5. Efficiency over the operating bandwidth. 

 

Observation Table: 

Frequency 

(GHz) 

Impedance 

Bandwidth 

(GHz) 

Gain (dB) Efficiency (%) Size (𝝺3) 

     

 

 

Conclusion:  

Various parameters of the dipole antenna are studied using HFSS /CST software. 

Problems:   

1. Design and Analysis of Dipole antenna at 1800 GHz with 10% IBW (Gain = 3dB) 
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EXPERIMENT - 2 

 

OBJECTIVE:   

1. To become familiar with the microstrip antenna. 

2. To design microstrip patch antenna and study the different antenna parameters. 

 

SOFTWARE USED: 

ANSYS HFSS Software 

THEORY: 

1. Familiarization with the microstrip antenna: 

Microstrip antennas are low profile, comfortable to planar and non-planar surfaces and 

mechanically robust when mounted on rigid surface. It is also known as “patch antenna”, 

“internal antenna” or “printed antenna”, which is a narrowband wide beam antenna. Mostly used 

at microwave frequencies. Fig.1 shows a few possible geometries of single radiating patch 

antenna. The patch is usually fed along the centreline to symmetry and thus minimizes the 

excitation of undesirable modes. It is preferred in aircraft, spacecraft, satellite and missile 

applications, where size, weight, cost, ease of installation and aerodynamic profile are constraints 

and low profile antennas may be required. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig. 1 Geometry of single radiating patch antenna 

 

quad arrow square circular ring square ring 

pentagon triangular circular square 

plaque cross arc L-shape 
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Substrates: 

There are a numerous number of substrates that can be used for the design of microstrip antennas 

whose dielectric constants are usually in the range of 2.2 ≤ 𝜀r ≤ 12. Thick substrates are desirable 

with lower dielectric constants where because they provide better efficiency, larger bandwidth, 

loosely bound fields for radiation into space, but at the expense of large element size. Similarly, 

thin substrates with higher dielectric constants are desirable for microwave circuitry because they 

require tightly bound fields to minimize undesired radiation and coupling and lead to smaller 

element sizes. However, because of their greater losses, they are less efficient and have relatively 

smaller bandwidths. Fig. 2 shows a few examples of substrates with their specification which is 

used for selection of particular substrates by the antenna designers. 

 

 
 

Fig. 2 Examples of different substrates 

 
Feeding Techniques: 

 

Fig. 3 shows the feeding techniques for the microstrip antennas. 

 
Fig. 3 Feeding methods of microstrip antennas. 
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Antenna Parameters: 

The antenna parameters are represented graphically to characterize the antenna by using the 

simulated and measured data. Some of the typical antenna parameters are: 

 S-parameters: For one port antenna only reflection coefficient i.e. S11 will be defined. In 

the context of antennas and feeders, the reflection coefficient is defined as the figure that 

quantifies how much of an electromagnetic wave is reflected by an impedance 

discontinuity in the transmission medium. 
 VSWR: It is the ratio between transmitted and reflected voltage standing waves in a radio 

frequency (RF) electrical transmission system. It is a measure of how efficiently RF 

power is transmitted from the power source, through a transmission line, and into the load 

(antenna). 

 Radiation Pattern: It is graphical representation of radiation properties of the antenna as a 

function of space. It describes how the antenna radiates energy out into free space (or 

how it receives energy). It is 3D – pattern, which can be visualized in simulation software 

like HFSS. It can be also represented in 2D – polar plot from two planes i.e., E-plane and 

H-plane.   

 Gain: Antenna Gain is the ratio of power transmitted in a certain direction with a specific 

reference point. Relation between gain and efficiency is G = e * D where ‘D’ is the 

directivity and ‘e’ if the efficiency   

 Efficiency: Antenna efficiency is how much RF power delivered to the antenna (from 

radio) is actually transmitted into the air.  
 Axial ratio: It states about the polarization of the designed antenna. 

 

2. Design of a microstrip patch antenna and study the different antenna parameters 

 

The rectangular patch is by far the most widely used configuration. It is very easy to analyse 

using both the transmission line and cavity models. 

 

The diagram of a basic half-wave patch antenna is shown in Figure 4. It consists of a large 

patch of metal into which energy is coupled from a microstrip feed. The physical patch 

dimensions are width W and length L. It is fed by a microstrip feed line with width which is 

usually chosen so that the characteristic impedance of the feed line is 50 ohms. Like any 

other device, an antenna has an input impedance. If the feed line shown in the diagram were 

connected directly to the edge of the antenna, the input impedance at that point would be in 

the hundreds of ohms, which would be a poor match to the 50 ohm line being connected 

there. To match the input line (which is 50 ohms) to the high impedance of the patch, a 

simple quarter-wave transformer is used. Such a transformer is visible on the microstrip 

patch board. 

 

A single-feed patch antenna like the one shown in Figure 4 resonates at a frequency 

determined by the length of the antenna L, which is approximately half a wavelength (taking 

into effect wavelength shortening by the substrate). The radiated polarization is parallel to 

edges of the patch in the resonant direction. Because the patch is backed by a ground plane, 

we expect most of the radiation to be on the patch side of the substrate, and very little 

radiation behind the ground plane. 



4 
 

        
(a) Top view                                                                    (b) Side view 

 

   Fig. 4 Top view and side view of conventional microstrip patch antenna 

 

DESIGN PROCEDURE: 

Based on the simplified formulation, a design procedure is outlined which leads to practical 

designs of rectangular microstrip antennas. The procedure assumes that the specified information 

includes the dielectric constant of the substrate (′𝜀𝑟′), the resonant frequency (′𝑓𝑟′), and the 

height of the substrate (′ℎ′). The procedure is as follows: 

1. Specify: ′𝜀𝑟′,  ′𝑓𝑟′ and ′ℎ′ . 
2. Determine ‘W’ and ‘L’. 

0 2

2 1r r

v
W

f 



, where, ′𝑣𝑜′ is the free space velocity of light. 

3. Determine the effective dielectric constant (′𝜀𝑟𝑒𝑓𝑓′)of the microstrip antenna using. 

1/21 1
[1 12 ]

2 2
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h
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  
   

4. Once W is found, determine the extension of the length (′∆𝐿′)using: 

( 0.3)( 0.264)

0.412

( 0.258)( 0.8)

reff
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W

L h
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h
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5. Now, the actual length of the patch can now be determined for ‘L’, 

0 0

1
2

2 r reff

L L
f   

  

 

6. Typical lengths of microstrip patches vary between,  
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0(0.47 0.49) (0.47 0.49) d

r

L





   

, where ′𝜆𝑑′ is the guided wavelength in the dielectric. 

The smaller the dielectric constant of the substrate, the larger is the fringing. Thus, the length of 

the microstrip patch is smaller. 

In contrast, the larger the dielectric constant, the more tightly the field are held within the 

substrate. Thus the fringing is smaller and the length is longer and closer to half wavelength in 

the dielectric 

After calculating the length and width of the patch, design and simulation of rectangular 

microstrip patch antenna in the ANSYS HFSS software should be done to study the antenna 

parameters. 

 

HFSS DESIGN STEPS AND OBSERVATIONS:  

This example has been shown for rectangular patch antenna resonating at 2.4 GHz on an FR-4 

epoxy substrate of dielectric constant 4.4 and thickness 1.6 mm. 

STEP1: Create a substrate by selecting a Box from upper palate of 60x60x1.6 mm3, substrate 

is FR4 epoxy. 
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STEP 2: Create a ground by selecting a Box from upper palate  of 60x60x0.035 mm3 , 

 material is copper. 

 

STEP-3: For modelling of  patch ,create a box by selecting a Box from upper palate  of 

29x38x0.035 mm3 , material is copper. 

 

STEP-4: For Inset_cut, Create a box by selecting a Box from upper palate  of 9.5x5x0.035 

mm3 of copper material. 
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STEP-5: At last, Subtract Inset_cut box from Patch by selecting both the box. 
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STEP-6: For giving feed to patch we have to create a feedline  by selecting a Box of 

30x3x0.035 mm3 at the feed point, of copper material. And unite it with the existing patch. 

 

STEP-7: For assigning the radiation boundary. Change the drawing plane to XY, Create a 

Radiation box by selecting a box of 80x80x50 mm3 , and assign boundary radiation. 

 

STEP-8: For assigning Excitation. Change the drawing plane to YZ. A rectangular sheet has 

been created at the feed end, and assign the lumped excitation properly. 
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STEP-9: Complete the solution setup by assigning solution setup and  solution frequency as 

2.4 GHz. 
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STEP-10: Add frequency sweep. 

 

STEP-11: Validate the structure and analyse all. For results, go to results section and choose 

rectangular plot . 
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RESULTS & DISCUSSION: 

❑ S- Parameter: 

 

STEP-12: Validate the structure and analyse all. For VSWR result, go to result section and 

choose rectangular plot. 
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❑ VSWR- Parameter: 

 

❑ 2D- Radiation Pattern: 

STEP-13_1: Define the infinite sphere. Assign proper trace. From the results section in 

the create farfield report. Rectangular plot 
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STEP-13_2: Change in Families  

 

 

 

STEP-14: 3D- Polar plot setting. From the results section in the create far field report. 3D 

polar plot. 
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❑ 3D Polar Plot: 

 

 

STEP-15_1: Gain plot setting. Assign in Trace. From the results section in the create farfield 

report. Rectangular plot 
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STEP-15_2: Assign in Families 
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❑ Gain Plot & Reflection coefficient 

 

STEP-16_1: Assign in Traces. From the results section in the create farfield report. 

Rectangular plot. 
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Step-16_2: Assign in Families.  

 

❑ Axial Ratio 
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PRECAUTIONS: 

1. Save the HFSS file before designing the antenna. 

2. Define infinite sphere and simulate again for far-field results. 

3. Choose the radiation box at least quarter wavelength from each side of the antenna 

geometry. 

DESIGN TASKS: 

1.   Microstrip patch antenna design  at 400 MHz with 20% IBW. 

 

2.   Microstrip patch antenna design  at 900 MHz with 20% IBW. 

 

3.   Microstrip patch antenna design  at 1800 MHz with 20% IBW. 

 

4.   Microstrip patch antenna design  at 3 GHz  with 20% IBW.  

 

 

 



 

Experiment no: 4 
 

Objective:  Design and analysis of a 2x2 antenna array using HFSS simulation 

software for 3.5 GHz 
 

Software used: Ansys HFSS EM software 
 

Theory: 
 

In the present world of communication, an antenna is one of the critical parts. An antenna is a resonating 

structure, radiating electromagnetic field waves in free space. Antenna shows a property known as reciprocity, 

which implies that it can be transmitting or receiving. Antennas are utilized as a part of any communication 

frameworks, Viz., wireless LAN, space investigation, and radar, etc. Antennas usually work in air or outer 

space, but can also be operated underwater or even through soil and rock at specific frequencies for short 

separations. 

Military applications, Radar applications, Satellite applications, and Airborne applications need a high gain 

antenna in the field. Antenna gain is the ability to focus radiation from an antenna. So, for high gain 

application, we need an antenna with higher gain, higher directivity, relatively lesser half-power beamwidth 

(HPBW). As we know, for a single antenna element, the radiation pattern is relatively broad, and each element 

provides low values of directivity (gain). So, for high gain, either we have to enlarge the dimensions of the 

single element, often leads to more directive characteristics with the drawback of higher fabrication cost, 

impractical size, weight, and it requires more power to operate. Another way to enlarge the dimensions of the 

antenna, without necessarily increasing the size of the individual element, is to form an assembly of radiating 

elements in an electrical and geometrical configuration. This new antenna, formed by multi-elements, is 

referred to as an array. The signals from the antennas are combined or processed in order to achieve improved 

performance over that of a single antenna. Such as, Side lobe level, Beam width, Directivity & Gain etc.  

 
 

Fig. 1. Antenna array evolution from single element to array  

 
Fig. 2. Antenna array classification  

 

 



 

NOTE: 

• Radiation characteristics of antenna array is dependent on excitation coefficients and spacing of 

individual elements in the array  

• Uniformly spaced arrays with spacing λg/2 give a SLL of -13.26 dB. Where, λg is the guided 

wavelength.  

 

 
Fig. 3. 2D radiation plot of uniform array  

 

The electric field strength is given by  

𝐸(𝜃) = 𝐸(𝑒𝑙𝑒𝑚𝑒𝑛𝑡). 𝐴𝐹(𝜃) 
where 𝐸(𝜃)=Total radiated field, 𝐸(𝑒𝑙𝑒𝑚𝑒𝑛𝑡)= Radiation pattern of antenna element, 𝐴𝐹(𝜃) = Array 

Factor 

Variation for spacing has exponential effect on the Array Factor, i.e., 

𝐴𝐹(𝜃) = ∑ 𝐴𝑛 exp[ 𝑗 (𝑘 ∑𝑑𝑖 cos(𝜃) + 𝜑𝑛)]

𝑛

𝑖=1

𝑁

𝑛=1
 

Where, 

𝑘 =
2𝜋

𝜆
 

𝜆 is free space wavelength 

𝜃 is angle of incident wave with respect to x axis 

𝑑𝑖 is the inter element spacing between (i-1)th and the ith  elements 

𝐴𝑛  is the amplitude of the nth element  

𝜑𝑛 is the phase of the nth element  

 

Design of a simple T- Junction Power Divider at 3.5 GHz: 

1. Selected an appropriate substrate of thickness (h) and dielectric constant (𝜀𝑟 ) for the design of 

the power divider.  

2. Calculate the wavelength 𝜆𝑔 from the given frequency specifications as follows:    𝜆𝑔 =
𝑐

√𝜀𝑟∗𝑓
 

     Where, c is the velocity of light in air. 

      f  is the frequency of operation of the coupler. 

      𝜀𝑟is the dielectric constant of the substrate. 
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3. Synthesize the physical parameters (length & width) for the λ/4 lines with impedances of Z0 

and √2 Z0 (Z0 is the characteristic impedance of microstrip line which is = 50 Ω).  

4. Calculate the physical parameters of the T-Junction power divider from the electrical parameters 

like Z0 and electrical length using the above given design procedure.  

 

o SIMULATION (ANSYS HFSS): 

 

➢ Power Divider Simulation at 3.5 GHz 

First of all, we have to calculate the dimensions of the 50 Ohm and 70.7 Ohm microstrip line width 

lengths. Use online microstrip line calculator for the calculation. 

 
Fig. 4. Microstrip Line calculator  

 

 
Fig. 5. 2-way Power divider HFSS structure, reflection coefficient and transmission parameter 

 

➢ 1x2 Antenna Array Simulation at 3.5 GHz 

 

 

50 Ohm 

50 Ohm 

70.7 Ohm 



 

➢ Results for 1x2 Antenna Array 

 

• S-Parameter: 

 

 
 

• Realized Gain: 

 

 

• 3D-Polar Plot: 

 
 



 

➢ Final 2x2 Antenna Array Simulation at 3.5 GHz 

 
 

➢ Results for 2x2 Antenna Array 

 

• S-Parameter: 

 
 



 

• Realized Gain: 

 

 

• 3D-Polar Plot: 

 
 

An advantage of antenna arrays is that since they have directive beams with high gain properties, they can 

operate over a radar, military applications, etc. The primary benefits of antenna array are given below: 

➢ The signal strength increases. 

➢ High directivity is obtained. 

➢ Minor lobes are reduced much. 

➢ High Signal-to-noise ratio is achieved. 

➢ High gain is obtained. 

➢ Power wastage is reduced. 

➢ Better performance is obtained. 
 

Simulated results: 
 
Add various plots for the proposed antenna performance: 

 
1.   -10 dB impedance bandwidth (BW in GHz) 



 

2.   Gain variations over whole operating BW (in dB) 

3.   2-D radiation patterns at different resonating frequencies 

4.   VSWR plot 

5.   3-D radiation patterns at different resonating frequencies 

6.   Efficiency over the operating band 

 

Observation Table: 
 

Frequency range of the 

antenna array (-10dB BW) 

Gain variations over 

the band 

VSWR Efficiency 

 

 
 

Conclusions: 
 

Please add some comments on these particular experiments related to the difficulties you have 

faced during simulation and also related to observation from variations of results with respect to 

different design parameters. Also mention some points related to necessary precaution that 

need to consider during simulation for getting desired results. 



Experiment no: 3 
 

Objective:  Design and analysis of conventional antennas like Waveguide 

based horn antenna. 
 

Software used: HFSS software. 
 

Theory: 
 

A horn antenna is an antenna that consists of a flaring metal waveguide shaped like a horn to direct radio 

waves in a beam. Horns are widely used as antennas at UHF and microwave frequencies, above 300 

MHz. They are used as feed antennas (called feed horns) for larger antenna structures such as parabolic 

antennas, and as directive antennas for devices like radar guns, automatic door openers, and microwave 

radiometers. Their advantages are moderate directivity, broad bandwidth, and simple construction and 

adjustment. 
 

The horn antenna is a simple development of the waveguide transmission line. Using some simple theory, 

it is easy to learn the operation of horn antenna. It is quite possible to leave a waveguide open and let 

signal radiate from this. However this is not particularly efficient. Signals passing along the waveguide 

see a sudden transition from the waveguide to free space which has an impedance of around 377Ω. The 

result of this sudden transition is to cause signals to be reflected back long the waveguide as standing waves 

as this is exactly the same as for poor matches at the end of coaxial or other forms of wire based transmission 

lines. To overcome this issue, the waveguide can be tapered out or flared. This has the effect of providing 

a gradual transition from the impedance of the waveguide to that of free space. In effect it acts like a 

progressive matching transformer. The flare functions similarly to a tapered transmission line, or an optical 

medium with a smoothly varying refractive index. In addition, the wide aperture of the horn projects the 

waves in a narrow beam. The waves of the signal will propagate down the horn antenna towards the aperture. 

As they travel along the flared opening, the waves travel as spherical wave fronts. As the phase front 

progressing along the horn antenna is spherical, the phase increases smoothly from the edges of the aperture 

plane to the centre. The difference in phase between the centre point and the edges is called the phase error. 

This increases with the flare angle reducing the gain, but increasing the beam width. As a result horn 

antennas have wider beam widths when compared to similar-sized plane-wave antennas like parabolic 

reflectors. In order to provide a narrow beam width a longer horn is required, i.e. having a smaller angle of 

flare. This enables the phase angle to be kept more constant. 

 

As  the  frequency used  by a  horn  antenna increases,  so  does  the  gain  and directivity (beam width 

decreases). The reason for this is that the aperture of the horn remains constant in terms of physical 

dimensions (obviously), but increases in terms of the number of wavelengths, i.e. it is electrically larger. 

As the flare angle is increased, the reflection at the mouth decreases rapidly and as a result the gain of the 

horn antenna increases. The horn antenna can operate very effectively. The flare of the horn antenna 

provides a smooth match between the waveguide and free space and its angle affects many properties 

including the gain and directivity. 

 

An advantage of horn antennas is that since they have no resonant elements, they can operate over a wide 

range of frequencies, a wide bandwidth. The uses of horn antenna are given below:



1. The horn is widely used as a feed element for large radio astronomy, satellite tracking, and 

communication dishes found installed throughout the world. 

 

2. In addition to its utility as a feed for reflectors and lenses, it is a common element of phased 

arrays. 

 

3. It  serves  as  a  universal  standard  for  calibration  and  gain  measurements  of  other  high-gain 

antennas. 

 

4. Its  widespread  applicability  stems  from  its  simplicity  in  construction,  ease  of  excitation, 

versatility, large gain, and preferred overall performance. 

 
 

Different types of horn antennas are shown in below figure. 

 
 

 
 

The cross-sectional view (E-plane and H-plane) of a pyramidal horn antenna is shown below. 
 

 



 
 

 

Design Procedure of Pyramidal horn antenna: 
 
To design a pyramidal horn, one usually knows the desired gain G0 and the dimensions a, b of the 

rectangular feed waveguide. 
 

The objective of the design is to determine the remaining dimensions (a1, b1, ρe , ρh , Pe , and Ph ) that 

will lead to an optimum gain. 

The design equations are derived by firsts electing values of a1 and b1that lead to optimum directivities 

for the E and H plane sectoral horns. 

 
 
 
 
 
 
 

Since the overall efficiency (including both the antenna and aperture efficiencies) of a horn antenna is 

about 50%. The gain of the antenna can be related to its physical area. Thus it can be written by 

 

 
 

 



Since for long horns ρ2 ≈ ρh and ρ1 ≈ ρe. For a pyramidal horn to be physically realizable, Pe and Ph 

must be equal. Using this equality, it can be shown that gain reduces to 

 

 
 

Where, 
 

  …………………..(1) 

This Equation is the horn design equation. 

 

1.   As a first step of the design, find the value of χ which satisfies eqn. (1) for a desired gain 

G0 (Dimensionless). Use an iterative technique and begin with a trial value of 

 

 

2.   Once the correct χ has been found, determine ρe and ρh using eqn. (1). 

3.   Find the corresponding values of a1 and b1. 

 
 

4.   Then find the value of pe and ph using following equations. 

 

𝑝𝑒 = (𝑏1 − 𝑏)√(
𝑝𝑒
𝑏1
)
2

−
1

4
 

 

𝑝ℎ = (𝑎1 − 𝑏)√(
𝑝ℎ
𝑎1
)
2

−
1

4
 

 

 

 

 

 

 



Design Problem: 
 
Design an X-band Horn antenna with the specifications as given below: Given: X-band (8.2 – 12.4 GHz), f = 

11 GHz Horn and Gain = 22.6 dB. Here, a = 0.9 inch, b = 0.4 inch. Find the dimensions of Pyramidal Horn 

antenna and then simulate that structure using HFSS software. 

 

Design procedure using HFSS software: 
 

1.   After opening of the HFSS software, design the wave guide feeding section as shown below. 

 

 
 

 

2.   Then, select the face and then “Modeler” – “Surface” – “Create object from face”. 
 



  

 
 

 

3.   Then right click on the surface and “Edit” – “Sweep” – “Along Vector”. 
 

 
 

4.   Choose “Draft angle” and “Draft type”. 
 

 
 
5.   Choose the length and angle from “Sweep along Vector”. 

 



 

6.   Then select the surface and “Edit” – “Surface” – “Uncover Faces”. 

 

 
 

7.   Then unite the structure and select it. After that “Edit” – “Surface” – “Thicken Sheet”. 
 

 
 

 

8.   An alternate approach to design: 
 



 

9.   Go to “Modeler” – “Surface” – “Connect” to create the horn antenna geometry and then follow 

the same steps as shown before. 

 

 
 
 

 
 

Simulated results: 
 
Add various plots for the proposed antenna performance: 

 
1.   -10 dB impedance bandwidth (BW in GHz) 

2.   Gain variations over whole operating BW (in dB) 

3.   2-D radiation patterns at different resonating frequencies 

4.   VSWR plot 

5.   3-D radiation patterns at different resonating frequencies 

6.   Efficiency over the operating band 

 

  Observation Table: 
 

Frequency 

range of the 

Horn antenna 

(-10dB BW) 

Gain 

variations 

over the 

band 

VSWR Cross- polarization 

suppression at 

different frequencies 

Efficiency 

 

 
 

Conclusions: 
 

Please add some comments on this particular experiments related to the difficulties you have 

faced during simulation and also related to observation from variations of results with respect to 

different design parameters. Also mentioned some points related to necessary precaution that 

need to consider during simulation for getting desired results. 
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